当前位置:首页 > 站长手册

用Apache模块做流量限制

citysnail4年前 (2023-01-08)站长手册98
用Apache模块做流量限制
也想来试试看 Windows 上能否做到
花费一两天的时间明查暗访下,终于给我找到啦~
找到后来才知道有个 http://modules.apache.org 网站
在里面找到一个 Bandwidth Module 的 module
Installing step:
1. 将 mod_bw.dll 放到安装 apache 资料夹下的 modules
2. 编辑 httpd.conf,将 LoadModule bw_module modules/mod_bw.dll 加入
3. 重开 apache
4. 查看 phpinfo() 里是否有 mod_bw
Configuration Directives:
1 - BandWidthModule [On|Off]
这个 module 预设是关闭的,要将他开启才能够使用。
Example:
BandWidthModule On 2 - ForceBandWidthModule [On|Off]
这个 module 预设不会过滤每个需求。
如果您开启他,他将处理过滤每个需求。
Example :
(正常的使用下,仅会过滤 text/html test/plain)
AddOutputFilterByType MOD_BW text/html text/plain
(开启的状况下)
ForceBandWidthModule On
3 - BandWidth [From] [bytes/s]
这边有两个参数。
From 是限制来源的位置,也就是该位置受限制。他可以是完整的 hostname、网域名称或 IP。可搭配遮罩使用,例如 192.168.0.0/24 or 192.168.0.0/255.255.255.0 。
另一个参数是限制的速率,以 bytes 每秒为单位;假如为 0,则不受限制。
Example :
BandWidth localhost 10240
BandWidth 192.168.218.5 0
( 依照设定的先后顺序为排序准则。Order is relevant. First entries have precedence )
4 - MinBandWidth [From] [bytes/s]
这边有两个参数。
From 是限制来源的位置,也就是该位置受限制。他可以是完整的 hostname、网域名称或 IP。可搭配遮罩使用,例如 192.168.0.0/24 or 192.168.0.0/255.255.255.0 。
另一个参数每个连线限制的最小速率,以 bytes/s 为单位,-1 代表无限制。
Examples :
BandWidth all 102400
MinBandWidth all 50000
The example above, will have a top speed of 100kb for the 1? client. If more clients come, it will be splitted accordingly but
everyone will have at least 50kb (even if you have 50 clients)
BandWidth all 50000
MinBandWidth all -1
上面的例子说明每个连线有 50kb 的速度(不限制最小速度)
5 - LargeFileLimit [Type] [Minimum Size] [bytes/s]
顾名思义,这设定是专门用来限制大型档案的。
Type 是指副档名,可以使用 * 代表全部。也可使用 .tgz 、 .avi 等。
Minimun Size 单位是 kbytes/s,只要超过这个 Size 就被规范在这个设定的限速中。
最后一个参数就是被限制的速率囉!
Example :
LargeFileLimit .avi 500 10240
This limits .avi files over (or equal to) 500kb to 10kbytes/s
6 - BandWidthPacket [Size]
可能您不需要去设定这个参数!
预设值为 8192,适用于任何速度。
这个设定必须介于 1024 至 131072。
小的封包将使得速度变慢,且更耗费系统效能;相反亦是。
7 - BandWidthError [Error]
这个选项是用来自订个人化错误讯息的。
在预设的情况下,超过最大连线时,这个 module 将会丢出 503 HTTP_SERVICE_UNAVAILABLE 回应。
对于大部分的人来说,他们会困扰着错误讯息,不知道为什么会这样。
你可以自订一个错误讯息的页面,去解释在什么情况下会发生这种问题。
但有时候错误号码 503 是不适用这个地方的。
所以你可以自订一个错误号码从 300 至 599。
( 有关 HTTP 错误讯息可参考下列 Reference: HTTP Protocol Error Codes)
在自订错误编码时请注意,要使用尚未被定义的号码!
测试的时候,我们使用错误号码 510(510尚未被定义)
And Example, with Personalized Error Page :
ErrorDocument 510 /errors/maxconexceeded.html
BandWidthError 510
注意:有时候自订错误编码可能会有问题。但在大部分的情况下,作者已修复。
8 - MaxConnection [From] [Max]
这个设定有两个参数。
From 是限制来源的位置,也就是该位置受限制。他可以是完整的 hostname、网域名称或 IP。可搭配遮罩使用,例如 192.168.0.0/24 or 192.168.0.0/255.255.255.0 。
第二个参数是设定最大的连线数量。假如连线超过这个数量,Apache 将丢出 503 Service Temporarily Unavailable 的讯息。
在设定这个参数之前,需先指定 BandWidth 值。
他不需要设定的太低,您可以设定为无限制。
Example :
BandWidth all 0
MaxConnection all 20
or
BandWidth all 0
BandWidth 192.168.0.0/24 10240
MaxConnection all 20
MaxConnection 192.168.0.0/24 5

示范区:
这个 module 设定可安插在 virtual host 或 directory,看你要设定在 httpd.conf 或 .htaccess 皆可!
不过使用 .htaccess 别忘了把 httpd.conf 里的 下的 AllowOverride 设为 ALL 。
1. 限制每个连线为 10kb/s
BandwidthModule On
ForceBandWidthModule On
Bandwidth all 10240
MinBandwidth all -1
Servername www.example.com
2. 限制每一个连线为 100 kb/s,最小的速率为 50kb/s,且当档案超过 500 kb 即限速为 50kb/s
BandwidthModule On
ForceBandWidthModule On
Bandwidth all 1024000
MinBandwidth all 50000
LargeFileLimit * 500 50000
Servername www.example.com
3. 限制副档名为 avi & mpeg 的档案为 20 kb/s
BandwidthModule On
ForceBandWidthModule On
LargeFileLimit .avi 1 20000
LargeFileLimit .mpg 1 20000
Servername www.example.com
4. 当档案(mime)为 text 格式,限制速度为 5kb/s
BandwidthModule On
AddOutputFilterByType MOD_BW text/html text/plain
Bandwidth all 5000
Servername www.example.com


扫描二维码推送至手机访问。

版权声明:本文由风云的博客发布,如需转载请注明出处。

本文链接:https://blog.flightnet.cn/?id=41

分享给朋友:

“用Apache模块做流量限制” 的相关文章

我们的网速到底是多快------Kbps和KBps的区别

1KBps=8Kbps下面解释:1、Kb和KB的区别:计算机中的信息都是二进制的0和1来表示,其中每一个0或1被称作一个位,用小写b表示,即bit(位);大写B表示byte,即字节,一个字节=八个位,即1B=8b;前面的大写K表示千的意思,即千个位(Kb)或千个字节(KB)。一般都使用字节(KB)来…

windows7权限问题 - windows 7 本地组策略编辑器

UAC的全称是User Account Control(用户账户控制),它是Windows Vista提供的一个安全特性。它会在用户使用计算机进行更改系统设置或者安装软件等会影响到系统安全性、稳定性的操作时弹出一个对话框,友善的提示用户他们要进行的操作。在我第一次使用Windows Vista时,每…

Apache设置虚拟目录——在虚拟主机中设置虚拟目录

设置方法:NameVirtualHost *:80    …

apache下新增文件下载类型

在把Apache Server装到Linux系统上面之后,Linux系统的/etc目录下就会新增一个httpd目录,用来存放所有的Apache的配置设定文件,而执行文件httpd则会被存放在/usb/sbin目录中,同时还会将一个名为mime.types的文件放到/etc目录下面。…

XAMPP Apache 无法启动解决办法

升级了Windows SP3之后,XAMPP就歇菜了,症状是无法正常启动Apache,显示busy。一番疑神疑鬼之后,没找到有效的解决方案(折腾了整整一天!),网络上这样的问题铺天盖地,看来是国际性的,不过大家都方法都是用CMD-->netstat -ano 查看端口占用情况,可是这次情况比较…

如何让IIS与Apache共用80端口方法

为调试程序,本机安装iis与apache,无法同时使用80端口,现给出解决方法: …